What’s Vulnerable › Vulnerabilities
CVE-2025-54128: HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-79
Description
HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.8 — fixed in 11.0.8
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/ddb9351c6d6418008d4084a5b17fd6d611bc4e30
- https://github.com/haxtheweb/issues/security/advisories/GHSA-59g8-h59f-8hjp
Get alerted when CVE-2025-54128 or the next vulnerability affects your stack