What’s Vulnerable › Vulnerabilities
CVE-2025-54130: Cursor Agent is vulnerable prompt injection via Editor Special Files
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-05 · updated 2026-06-17
- Weakness: CWE-285
Description
Cursor is a code editor built for programming with AI. Cursor allows writing in-workspace files with no user approval in versions less than 1.3.9. If the file is a dotfile, editing it requires approval but creating a new one doesn't. Hence, if sensitive editor files, such as the .vscode/settings.json file don't already exist in the workspace, an attacker can chain a indirect prompt injection vulnerability to hijack the context to write to the settings file and trigger RCE on the victim without user approval. This is fixed in version 1.3.9.
Affected products
- cursor: before 1.3.9 — fixed in 1.3.9
How to fix
Upgrade to a fixed version: cursor 1.3.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54130 or the next vulnerability affects your stack