What’s Vulnerable › Vulnerabilities
CVE-2025-54131: Cursor bypasses its allow list to execute arbitrary commands
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-77
Description
Cursor is a code editor built for programming with AI. In versions below 1.3, an attacker can bypass the allow list in auto-run mode with a backtick (`) or $(cmd). If a user has swapped Cursor from its default settings (requiring approval for every terminal call) to an allowlist, an attacker can execute arbitrary command execution outside of the allowlist without user approval. An attacker can trigger this vulnerability if chained with indirect prompt injection. This is fixed in version 1.3.
Affected products
- cursor: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: cursor 1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54131 or the next vulnerability affects your stack