What’s Vulnerable › Vulnerabilities
CVE-2025-54134: HAX CMS NodeJs's Improper Error Handling Leads to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-21 · updated 2026-06-17
- Weakness: CWE-20
Description
HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.8 and below, the HAX CMS NodeJS application crashes when an authenticated attacker provides an API request lacking required URL parameters. This vulnerability affects the listFiles and saveFiles endpoints. This vulnerability exists because the application does not properly handle exceptions which occur as a result of changes to user-modifiable URL parameters. This is fixed in version 11.0.9.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.9 — fixed in 11.0.9
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/blob/main/src/routes/listFiles.js#L22
- https://github.com/haxtheweb/haxcms-nodejs/blob/main/src/routes/saveFile.js#L52
- https://github.com/haxtheweb/haxcms-nodejs/commit/e9773d1996233f9bafb06832b8220ec2a98bab34
- https://github.com/haxtheweb/issues/security/advisories/GHSA-pjj3-j5j6-qj27
Get alerted when CVE-2025-54134 or the next vulnerability affects your stack