What’s Vulnerable › Vulnerabilities
CVE-2025-54139: HAX CMS' application pages are vulnerable to clickjacking
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-23 · updated 2026-06-17
- Weakness: CWE-1021
Description
HAX CMS allows users to manage their microsite universe with a NodeJS or PHP backend. In haxcms-nodejs versions 11.0.12 and below and in haxcms-php versions 11.0.7 and below, all pages within the HAX CMS application do not contain headers to prevent other websites from loading the site within an iframe. This applies to both the CMS and generated sites. An unauthenticated attacker can load the standalone login page or other sensitive functionality within an iframe, performing a UI redressing attack (clickjacking). This can be used to perform social engineering attacks to attempt to coerce users into performing unintended actions within the HAX CMS application. This is fixed in haxcms-nodejs version 11.0.13 and haxcms-php 11.0.8.
Affected products
- haxtheweb haxcms-nodejs: from 11.0.6 before 11.0.13 — fixed in 11.0.13
- haxtheweb haxcms-php: from 11.0.0 before 11.0.8 — fixed in 11.0.8
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.13; haxtheweb haxcms-php 11.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/777f9a7ff9675a160496f350d766df1f1f9b9b99
- https://github.com/haxtheweb/haxcms-php/commit/708dc8518928fe307044e67bff8b0f397cfdd606
- https://github.com/haxtheweb/issues/security/advisories/GHSA-54vw-f4xf-f92j
- https://github.com/haxtheweb/issues/security/advisories/GHSA-54vw-f4xf-f92j
Get alerted when CVE-2025-54139 or the next vulnerability affects your stack