What’s Vulnerable › Vulnerabilities
CVE-2025-54154: QNAP Authenticator
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-03 · updated 2026-10-18
- Weakness: CWE-287
Description
An improper authentication vulnerability has been reported to affect QNAP Authenticator. If an attacker gains physical access, they can then exploit the vulnerability to compromise the security of the system. We have already fixed the vulnerability in the following version: QNAP Authenticator 1.3.1.1227 and later
Affected products
- QNAP Systems Inc. QNAP Authenticator: from 1.3.0 before 1.3.1.1227 — fixed in 1.3.1.1227
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QNAP Authenticator 1.3.1.1227. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54154 or the next vulnerability affects your stack