What’s Vulnerable › Vulnerabilities
CVE-2025-54167: Notification Center
- Severity: high (CVSS 7.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-10-18
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect Notification Center. If a remote attacker gains an administrator account, they can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following versions: Notification Center 2.1.0.3443 and later Notification Center 1.9.2.3163 and later Notification Center 3.0.0.3466 and later
Affected products
- QNAP Systems Inc. Notification Center: from 2.1.x before 2.1.0.3443; from 1.9.x before 1.9.2.3163; from 3.0.x before 3.0.0.3466 — fixed in 1.9.2.3163, 2.1.0.3443, 3.0.0.3466
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Notification Center 1.9.2.3163, 2.1.0.3443, 3.0.0.3466. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54167 or the next vulnerability affects your stack