What’s Vulnerable › Vulnerabilities
CVE-2025-54232: Adobe Framemaker | Use After Free (CWE-416)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-416
Description
Adobe Framemaker versions 2020.8, 2022.6 and earlier are affected by a Use After Free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: before 2020.9; from 2022 before 2022.7 — fixed in 2020.9, 2022.7
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.9, 2022.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54232 or the next vulnerability affects your stack