What’s Vulnerable › Vulnerabilities

CVE-2025-54239: After Effects | Out-of-bounds Read (CWE-125)

Description

After Effects versions 25.3, 24.6.7 and earlier are affected by an out-of-bounds read vulnerability that could lead to memory exposure, potentially disclosing sensitive information. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe After Effects 24.6.8, 25.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-54239 or the next vulnerability affects your stack