What’s Vulnerable › Vulnerabilities
CVE-2025-54241: After Effects | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-125
Description
After Effects versions 25.3, 24.6.7 and earlier are affected by an out-of-bounds read vulnerability that could lead to memory exposure, potentially disclosing sensitive information. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: before 24.6.8; from 25.0 before 25.4 — fixed in 24.6.8, 25.4
How to fix
Upgrade to a fixed version: Adobe After Effects 24.6.8, 25.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54241 or the next vulnerability affects your stack