What’s Vulnerable › Vulnerabilities
CVE-2025-54255: Acrobat Reader | Violation of Secure Design Principles (CWE-657)
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-657
Description
Acrobat Reader versions 24.001.30254, 20.005.30774, 25.001.20672 and earlier are affected by a Violation of Secure Design Principles vulnerability that could result in a security feature bypass impacting integrity. An attacker does not have to be authenticated. Exploitation of this issue does not require user interaction, and scope is unchanged.
Affected products
- Adobe Acrobat for Edge: from 24.0.0 before 24.001.30264; from 20.001.30002 before 20.005.30793; from 20.001.30002 before 20.005.30791 — fixed in 20.005.30791, 20.005.30793, 24.001.30264
- Adobe Acrobat DC: from 15.008.20082 before 25.001.20693 — fixed in 25.001.20693
- Adobe Acrobat Reader: from 20.001.30002 before 20.005.30791 — fixed in 20.005.30791
- Adobe Acrobat Reader: from 15.008.20082 before 25.001.20693 — fixed in 25.001.20693
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30791, 20.005.30793, 24.001.30264; Adobe Acrobat DC 25.001.20693; Adobe Acrobat Reader 20.005.30791; Adobe Acrobat Reader 25.001.20693. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54255 or the next vulnerability affects your stack