What’s Vulnerable › Vulnerabilities
CVE-2025-54256: Dreamweaver Desktop | Cross-Site Request Forgery (CSRF) (CWE-352)
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-09 · updated 2026-06-17
- Weakness: CWE-352
Description
Dreamweaver Desktop versions 21.5 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must click on a malicious link, and scope is changed.
Affected products
- Adobe Dreamweaver Desktop: before 21.6 — fixed in 21.6
How to fix
Upgrade to a fixed version: Adobe Dreamweaver Desktop 21.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54256 or the next vulnerability affects your stack