What’s Vulnerable › Vulnerabilities

CVE-2025-54257: Acrobat Reader | Use After Free (CWE-416)

Description

Acrobat Reader versions 24.001.30254, 20.005.30774, 25.001.20672 and earlier are affected by a Use After Free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file, and scope is unchanged.

Affected products

How to fix

Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30791, 20.005.30793, 24.001.30264; Adobe Acrobat DC 25.001.20693; Adobe Acrobat Reader 20.005.30791; Adobe Acrobat Reader 25.001.20693. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-54257 or the next vulnerability affects your stack