What’s Vulnerable › Vulnerabilities
CVE-2025-54282: Adobe Framemaker | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-14 · updated 2026-10-08
- Weakness: CWE-122
Description
Adobe Framemaker versions 2020.9, 2022.7 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: before 2020.10; from 2022 before 2022.8 — fixed in 2020.10, 2022.8
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.10, 2022.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54282 or the next vulnerability affects your stack