What’s Vulnerable › Vulnerabilities

CVE-2025-54286: CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI

Description

Cross-Site Request Forgery (CSRF) in LXD-UI in Canonical LXD versions >= 5.0 on Linux allows an attacker to create and start container instances without user consent via crafted HTML form submissions exploiting client certificate authentication.

Affected products

How to fix

Upgrade to a fixed version: Canonical LXD 5.0.5, 5.21.4, 6.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-54286 or the next vulnerability affects your stack