What’s Vulnerable › Vulnerabilities
CVE-2025-54288: Source Container Identification Vulnerability via cmdline Spoofing in devLXD Server
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-02 · updated 2026-10-12
- Weakness: CWE-290
Description
Information Spoofing in devLXD Server in Canonical LXD versions 4.0 and above on Linux container platforms allows attackers with root privileges within any container to impersonate other containers and obtain their metadata, configuration, and device information via spoofed process names in the command line.
Affected products
- Canonical LXD: from 4.0.0 before 5.21.4; from 6.1 before 6.5 — fixed in 5.21.4, 6.5
How to fix
Upgrade to a fixed version: Canonical LXD 5.21.4, 6.5. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-7232-97c6-j525
- https://github.com/canonical/lxd/security/advisories/GHSA-7232-97c6-j525
Get alerted when CVE-2025-54288 or the next vulnerability affects your stack