What’s Vulnerable › Vulnerabilities
CVE-2025-54292: Client-Side Path Traversal in LXD-UI
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-02 · updated 2026-10-12
- Weakness: CWE-22
Description
Path traversal in Canonical LXD LXD-UI versions before 6.5 and 5.21.4 on all platforms allows remote authenticated attackers to access or modify unintended resources via crafted resource names embedded in URL paths.
Affected products
- Canonical LXD: from 5.0.0 before 5.21.4; from 6.0 before 6.5 — fixed in 5.21.4, 6.5
How to fix
Upgrade to a fixed version: Canonical LXD 5.21.4, 6.5. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-7425-4qpj-v4w3
- https://github.com/canonical/lxd/security/advisories/GHSA-7425-4qpj-v4w3
Get alerted when CVE-2025-54292 or the next vulnerability affects your stack