What’s Vulnerable › Vulnerabilities
CVE-2025-54313: Prettier eslint-config-prettier Embedded Malicious Code Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-01-22
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-19 · updated 2026-06-17
- Weakness: CWE-506
Description
eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.
Affected products
- Alexghr Got-Fetch: 5.1.1, 5.1.2
- homarr-labs homarr: from 1.29.0 before 1.30.0 — fixed in 1.30.0
- prettier eslint-config-prettier: 8.10.1, 9.1.1, 10.1.6, 10.1.7
- prettier Eslint-Plugin-Prettier: 4.2.2, 4.2.3
- Un-Ts Napi-Postinstall: 0.3.1
- Un-Ts Pkgr/Core: 0.2.8
- Un-Ts Synckit: 0.11.9
How to fix
Upgrade to a fixed version: homarr-labs homarr 1.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/prettier/eslint-config-prettier/issues/339
- https://news.ycombinator.com/item?id=44608811
- https://news.ycombinator.com/item?id=44609732
- https://socket.dev/blog/npm-phishing-campaign-leads-to-prettier-tooling-packages-compromise
- https://www.bleepingcomputer.com/news/security/popular-npm-linter-packages-hijacked-via-phishing-to-drop-malware/
- https://www.npmjs.com/package/eslint-config-prettier?activeTab=versions
- https://www.stepsecurity.io/blog/supply-chain-security-alert-eslint-config-prettier-package-shows-signs-of-compromise
- https://github.com/community-scripts/ProxmoxVE/discussions/6115
- https://www.endorlabs.com/learn/cve-2025-54313-eslint-config-prettier-compromise----high-severity-but-windows-only
- https://www.bleepingcomputer.com/news/security/popular-npm-linter-packages-hijacked-via-phishing-to-drop-malware/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-54313
Get alerted when CVE-2025-54313 or the next vulnerability affects your stack