What’s Vulnerable › Vulnerabilities
CVE-2025-54314
- Severity: low (CVSS 2.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-20 · updated 2026-06-17
- Weakness: CWE-78
Description
Thor before 1.4.0 can construct an unsafe shell command from library input. NOTE: this is disputed by the Supplier because "the method that was fixed can only be used with arguments that are controlled by Thor, and there is no way an attacker can take control of those arguments."
Affected products
- rubyonrails Thor: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: rubyonrails Thor 1.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/github/advisory-database/pull/5912#issuecomment-3169255309
- https://github.com/rails/thor/commit/536b79036a0efb765c1899233412e7b1ca94abfa
- https://github.com/rails/thor/pull/897
- https://github.com/rails/thor/releases/tag/v1.4.0
- https://hackerone.com/reports/3260153
Get alerted when CVE-2025-54314 or the next vulnerability affects your stack