What’s Vulnerable › Vulnerabilities
CVE-2025-54349
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-03 · updated 2026-06-17
- Weakness: CWE-193
Description
In iperf before 3.19.1, iperf_auth.c has an off-by-one error and resultant heap-based buffer overflow.
Affected products
- ES iperf3: from 3.2 before 3.19.1 — fixed in 3.19.1
How to fix
Upgrade to a fixed version: ES iperf3 3.19.1. Check the vendor advisory for mitigations.
References
- https://github.com/esnet/iperf/commit/4e5313bab0b9b3fe03513ab54f722c8a3e4b7bdf
- https://github.com/esnet/iperf/releases/tag/3.19.1
- https://lists.debian.org/debian-lts-announce/2025/08/msg00020.html
Get alerted when CVE-2025-54349 or the next vulnerability affects your stack