What’s Vulnerable › Vulnerabilities
CVE-2025-54368: uv is vulnerable to ZIP payload obfuscation through parsing differentials
- Severity: medium (CVSS 6.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-08 · updated 2026-06-17
- Weakness: CWE-20
Description
uv is a Python package and project manager written in Rust. In versions 0.8.5 and earlier, remote ZIP archives were handled in a streamwise fashion, and file entries were not reconciled against the archive's central directory. An attacker could contrive a ZIP archive that would extract with legitimate contents on some package installers, and malicious contents on others due to multiple local file entries. An attacker could also contrive a "stacked" ZIP input with multiple internal ZIPs, which would be handled differently by different package installers. The attacker could choose which installer to target in both scenarios. This issue is fixed in version 0.8.6. To work around this issue, users may choose to set UV_INSECURE_NO_ZIP_VALIDATION=1 to revert to the previous behavior.
Affected products
- astral-sh uv: before 0.8.6
References
- https://astral.sh/blog/uv-security-advisory-cve-2025-54368
- https://blog.pypi.org/posts/2025-08-07-wheel-archive-confusion-attacks
- https://github.com/astral-sh/uv/commit/7f1eaf48c193e045ca2c62c4581048765c55505f
- https://github.com/astral-sh/uv/security/advisories/GHSA-8qf3-x8v5-2pj8
Get alerted when CVE-2025-54368 or the next vulnerability affects your stack