What’s Vulnerable › Vulnerabilities
CVE-2025-54377: Roo Code Lacks Line Break Validation in its Command Execution Tool
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-23 · updated 2026-06-17
- Weakness: CWE-77
Description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. In versions 3.23.18 and below, RooCode does not validate line breaks (\n) in its command input, allowing potential bypass of the allow-list mechanism. The project appears to lack parsing or validation logic to prevent multi-line command injection. When commands are evaluated for execution, only the first line or token may be considered, enabling attackers to smuggle additional commands in subsequent lines. This is fixed in version 3.23.19.
Affected products
- RooCodeInc Roo-Code: before 3.23.19 — fixed in 3.23.19
How to fix
Upgrade to a fixed version: RooCodeInc Roo-Code 3.23.19. Check the vendor advisory for mitigations.
References
- https://github.com/RooCodeInc/Roo-Code/commit/9d434c2db9b20eb5c78b698cb2b0037cd2074534
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-p278-52x9-cffx
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-p278-52x9-cffx
Get alerted when CVE-2025-54377 or the next vulnerability affects your stack