What’s Vulnerable › Vulnerabilities
CVE-2025-54378: HAX CMS Backend Lacks Comprehensive Authorization Checks
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-26 · updated 2026-06-17
- Weakness: CWE-285
Description
HAX CMS allows you to manage your microsite universe with PHP or NodeJs backends. In versions 11.0.13 and below of haxcms-nodejs and versions 11.0.8 and below of haxcms-php, API endpoints do not perform authorization checks when interacting with a resource. Both the JS and PHP versions of the CMS do not verify that a user has permission to interact with a resource before performing a given operation. The API endpoints within the HAX CMS application check if a user is authenticated, but don't check for authorization before performing an operation. This is fixed in versions 11.0.14 of haxcms-nodejs and 11.0.9 of haxcms-php.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.14 — fixed in 11.0.14
- haxtheweb haxcms-php: before 11.0.9 — fixed in 11.0.9
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.14; haxtheweb haxcms-php 11.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/5826e9b7f3d8c7c7635411768b86b199fad36969
- https://github.com/haxtheweb/haxcms-php/commit/24d30222481ada037597c4d7c0a51a1ef7af6cfd
- https://github.com/haxtheweb/issues/security/advisories/GHSA-9jr9-8ff3-m894
- https://github.com/haxtheweb/issues/security/advisories/GHSA-9jr9-8ff3-m894
Get alerted when CVE-2025-54378 or the next vulnerability affects your stack