What’s Vulnerable › Vulnerabilities
CVE-2025-54386: Traefik's Client Plugin is Vulnerable to Path Traversal, Arbitrary File Overwrites and Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Traefik is an HTTP reverse proxy and load balancer. In versions 2.11.27 and below, 3.0.0 through 3.4.4 and 3.5.0-rc1, a path traversal vulnerability was discovered in WASM Traefik’s plugin installation mechanism. By supplying a maliciously crafted ZIP archive containing file paths with ../ sequences, an attacker can overwrite arbitrary files on the system outside of the intended plugin directory. This can lead to remote code execution (RCE), privilege escalation, persistence, or denial of service. This is fixed in versions 2.11.28, 3.4.5 and 3.5.0.
Affected products
- Traefik: before 2.11.7; from 3.0.0 before 3.4.4; 3.5.0, 3.5.0-rc1, 3.5.0-rc2 — fixed in 2.11.7, 3.4.4
How to fix
Upgrade to a fixed version: Traefik 2.11.7, 3.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/traefik/plugin-service/pull/71
- https://github.com/traefik/plugin-service/pull/72
- https://github.com/traefik/traefik/commit/5ef853a0c53068f69a6c229a5815a0dc6e0a8800
- https://github.com/traefik/traefik/pull/11911
- https://github.com/traefik/traefik/releases/tag/v2.11.28
- https://github.com/traefik/traefik/security/advisories/GHSA-q6gg-9f92-r9wg
Get alerted when CVE-2025-54386 or the next vulnerability affects your stack