What’s Vulnerable › Vulnerabilities
CVE-2025-54387: IPX is Vulnerable to Path Traversal via Prefix Matching Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-05 · updated 2026-06-17
- Weakness: CWE-22
Description
IPX is an image optimizer powered by sharp and svgo. In versions 1.3.1 and below, 2.0.0-0 through 2.1.0, and 3.0.0 through 3.1.0, the approach used to check whether a path is within allowed directories is vulnerable to path prefix bypass when the allowed directories do not end with a path separator. This occurs because the check relies on a raw string prefix comparison. This is fixed in versions 1.3.2, 2.1.1 and 3.1.1.
Affected products
- unjs ipx: before 1.3.2; from 2.0.0 before 2.1.1; from 3.0.0 before 3.1.1 — fixed in 1.3.2, 2.1.1, 3.1.1
How to fix
Upgrade to a fixed version: unjs ipx 1.3.2, 2.1.1, 3.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/unjs/ipx/commit/81693ddbfc062cc922e4e2406e8427ab4e3ad214
- https://github.com/unjs/ipx/releases/tag/v1.3.2
- https://github.com/unjs/ipx/releases/tag/v2.1.1
- https://github.com/unjs/ipx/releases/tag/v3.1.1
- https://github.com/unjs/ipx/security/advisories/GHSA-mm3p-j368-7jcr
- https://github.com/unjs/ipx/security/advisories/GHSA-mm3p-j368-7jcr
Get alerted when CVE-2025-54387 or the next vulnerability affects your stack