What’s Vulnerable › Vulnerabilities
CVE-2025-54417: Craft contains a theoretical bypass for CVE-2025-23209
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-09 · updated 2026-06-17
- Weakness: CWE-94
Description
Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.
Affected products
- craftcms cms: from 4.13.8 before 4.16.3; from 5.5.8 before 5.8.4 — fixed in 4.16.3, 5.8.4
How to fix
Upgrade to a fixed version: craftcms cms 4.16.3, 5.8.4. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/a19d46be78a9ca1ea474012a10e97bed0d787f57
- https://github.com/craftcms/cms/security/advisories/GHSA-2vcf-qxv3-2mgw
Get alerted when CVE-2025-54417 or the next vulnerability affects your stack