What’s Vulnerable › Vulnerabilities
CVE-2025-54424: 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-77
Description
1Panel is a web interface and MCP Server that manages websites, files, containers, databases, and LLMs on a Linux server. In versions 2.0.5 and below, the HTTPS protocol used for communication between the Core and Agent endpoints has incomplete certificate verification during certificate validation, leading to unauthorized interface access. Due to the presence of numerous command execution or high-privilege interfaces in 1Panel, this results in Remote Code Execution (RCE). This is fixed in version 2.0.6. The CVE has been translated from Simplified Chinese using GitHub Copilot.
Affected products
- 1Panel-dev 1Panel: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: 1Panel-dev 1Panel 2.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/1Panel-dev/1Panel/pull/9698/commits/4003284521f8d31ddaf7215d1c30ab8b4cdb0261
- https://github.com/1Panel-dev/1Panel/releases/tag/v2.0.6
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-8j63-96wh-wh3j
- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-8j63-96wh-wh3j
Get alerted when CVE-2025-54424 or the next vulnerability affects your stack