What’s Vulnerable › Vulnerabilities
CVE-2025-54478: Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-11 · updated 2026-06-17
- Weakness: CWE-306
Description
Mattermost Confluence Plugin version <1.5.0 fails to enforce authentication of the user to the Mattermost instance which allows unauthenticated attackers to edit channel subscriptions via API call to the edit channel subscription endpoint.
Affected products
- Mattermost Confluence Plugin: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Mattermost Confluence Plugin 1.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54478 or the next vulnerability affects your stack