What’s Vulnerable › Vulnerabilities
CVE-2025-5455: Possible denial of service when passing malformed data in a URL to qDecodeDataUrl
- Severity: high (CVSS 8.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-02 · updated 2026-07-29
- Weakness: CWE-20
Description
An issue was found in the private API function qDecodeDataUrl() in QtCore, which is used in QTextDocument and QNetworkReply, and, potentially, in user code. If the function was called with malformed data, for example, an URL that contained a "charset" parameter that lacked a value (such as "data:charset,"), and Qt was built with assertions enabled, then it would hit an assertion, resulting in a denial of service (abort). This impacts Qt up to 5.15.18, 6.0.0->6.5.8, 6.6.0->6.8.3 and 6.9.0. This has been fixed in 5.15.19, 6.5.9, 6.8.4 and 6.9.1.
Affected products
- Qt: through 5.15.18; from 6.0.0 through 6.5.8; from 6.6.0 through 6.8.3; 6.9.0
References
Get alerted when CVE-2025-5455 or the next vulnerability affects your stack