What’s Vulnerable › Vulnerabilities
CVE-2025-54558
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-25 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenAI Codex CLI before 0.9.0 auto-approves ripgrep (aka rg) execution even with the --pre or --hostname-bin or --search-zip or -z flag.
Affected products
- OpenAI Codex CLI: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: OpenAI Codex CLI 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/openai/codex/commit/6cf4b96f9dbbef8a94acc1ff703eb118481514d8
- https://github.com/openai/codex/compare/rust-v0.8.0...rust-v0.9.0
- https://github.com/openai/codex/pull/1644
Get alerted when CVE-2025-54558 or the next vulnerability affects your stack