What’s Vulnerable › Vulnerabilities
CVE-2025-54571: ModSecurity's Insufficient Return Value Handling can Lead to XSS and Source Code Disclosure
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-06 · updated 2026-06-17
- Weakness: CWE-252
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. In versions 2.9.11 and below, an attacker can override the HTTP response’s Content-Type, which could lead to several issues depending on the HTTP scenario. For example, we have demonstrated the potential for XSS and arbitrary script source code disclosure in the latest version of mod_security2. This issue is fixed in version 2.9.12.
Affected products
- owasp-modsecurity ModSecurity: from 2.0.0 before 2.9.12 — fixed in 2.9.12
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 2.9.12. Check the vendor advisory for mitigations.
References
- https://github.com/owasp-modsecurity/ModSecurity/commit/6d7e8eb18f2d7d368fb8e29516fcdeaeb8d349b8
- https://github.com/owasp-modsecurity/ModSecurity/issues/2514
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-cg44-9m43-3f9v
- https://lists.debian.org/debian-lts-announce/2025/09/msg00008.html
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-cg44-9m43-3f9v
Get alerted when CVE-2025-54571 or the next vulnerability affects your stack