What’s Vulnerable › Vulnerabilities
CVE-2025-54572: Ruby SAML DOS vulnerability with large SAML response
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-400
Description
The Ruby SAML library is for implementing the client side of a SAML authorization. In versions 1.18.0 and below, a denial-of-service vulnerability exists in ruby-saml even with the message_max_bytesize setting configured. The vulnerability occurs because the SAML response is validated for Base64 format prior to checking the message size, leading to potential resource exhaustion. This is fixed in version 1.18.1.
Affected products
- Rubygems Ruby-Saml: before 1.18.1; 0.0.5, 0.0.6, 0.0.7, 0.0.8, 0.2.1, 0.2.2 (+82) — fixed in 1.18.1
- SAML-Toolkits ruby-saml: before 1.18.1
How to fix
Upgrade to a fixed version: Rubygems Ruby-Saml 1.18.1. Check the vendor advisory for mitigations.
References
- https://github.com/SAML-Toolkits/ruby-saml/commit/38ef5dd1ce17514e202431f569c4f5633e6c2709
- https://github.com/SAML-Toolkits/ruby-saml/pull/770
- https://github.com/SAML-Toolkits/ruby-saml/releases/tag/v1.18.1
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-rrqh-93c8-j966
- https://lists.debian.org/debian-lts-announce/2025/09/msg00001.html
Get alerted when CVE-2025-54572 or the next vulnerability affects your stack