What’s Vulnerable › Vulnerabilities
CVE-2025-54581: vproxy is vulnerable to a divide by zero DoS attack
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-369
Description
vproxy is an HTTP/HTTPS/SOCKS5 proxy server. In versions 2.3.3 and below, untrusted data is extracted from the user-controlled HTTP Proxy-Authorization header and passed to Extension::try_from and flows into parse_ttl_extension where it is parsed as a TTL value. If an attacker supplies a TTL of zero (e.g. by using a username such as 'configuredUser-ttl-0'), the modulo operation 'timestamp % ttl' will cause a division by zero panic, causing the server to crash causing a denial-of-service. This is fixed in version 2.4.0.
Affected products
- 0x676e67 vproxy: before 2.4.0
References
- https://github.com/0x676e67/vproxy/commit/aa1bf64c5e7f1c471395f9f29175ffc1b16a1079
- https://github.com/0x676e67/vproxy/releases/tag/v2.4.0
- https://github.com/0x676e67/vproxy/security/advisories/GHSA-7h24-c332-p48c
Get alerted when CVE-2025-54581 or the next vulnerability affects your stack