What’s Vulnerable › Vulnerabilities
CVE-2025-54584: GitProxy is vulnerable to a packfile parsing exploit
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-115
Description
GitProxy is an application that stands between developers and a Git remote endpoint (e.g., github.com). In versions 1.19.1 and below, an attacker can craft a malicious Git packfile to exploit the PACK signature detection in the parsePush.ts file. By embedding a misleading PACK signature within commit content and carefully constructing the packet structure, the attacker can trick the parser into treating invalid or unintended data as the packfile. Potentially, this would allow bypassing approval or hiding commits. This issue is fixed in version 1.19.2.
Affected products
- finos Gitproxy: before 1.19.2 — fixed in 1.19.2
How to fix
Upgrade to a fixed version: finos Gitproxy 1.19.2. Check the vendor advisory for mitigations.
References
- https://github.com/finos/git-proxy/commit/333c98a165a5a1ec88414db3d4a2c6f81e083e0f
- https://github.com/finos/git-proxy/commit/a620a2f33c39c78e01783a274580bf822af3cc3a
- https://github.com/finos/git-proxy/releases/tag/v1.19.2
- https://github.com/finos/git-proxy/security/advisories/GHSA-xxmh-rf63-qwjv
Get alerted when CVE-2025-54584 or the next vulnerability affects your stack