What’s Vulnerable › Vulnerabilities
CVE-2025-54585: GitProxy is vulnerable to a new branch approval exploit
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-30 · updated 2026-06-17
- Weakness: CWE-285
Description
GitProxy is an application that stands between developers and a Git remote endpoint. In versions 1.19.1 and below, attackers can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. The vulnerability impacts all users or organizations relying on GitProxy to enforce policy and prevent unapproved changes. It requires no elevated privileges beyond regular push access, and no extra user interaction. It does however, require a GitProxy administrator or designated user (canUserApproveRejectPush) to approve pushes to the child branch. This is fixed in version 1.19.2.
Affected products
- finos Gitproxy: before 1.19.2 — fixed in 1.19.2
How to fix
Upgrade to a fixed version: finos Gitproxy 1.19.2. Check the vendor advisory for mitigations.
References
- https://github.com/finos/git-proxy/commit/a620a2f33c39c78e01783a274580bf822af3cc3a
- https://github.com/finos/git-proxy/commit/f99fe42082eab0970e4cd0acdc3421a527a7e531
- https://github.com/finos/git-proxy/releases/tag/v1.19.2
- https://github.com/finos/git-proxy/security/advisories/GHSA-39p2-8hq9-fwj6
Get alerted when CVE-2025-54585 or the next vulnerability affects your stack