What’s Vulnerable › Vulnerabilities
CVE-2025-5459: OS Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-09-04
- Weakness: CWE-78
Description
A user with specific node group editing permissions and a specially crafted class parameter could be used to execute commands as root on the primary host. It affects Puppet Enterprise versions 2018.1.8 through 2023.8.3 and 2025.3 and has been resolved in versions 2023.8.4 and 2025.4.0.
Affected products
- Puppet Enterprise: from 2018.1.8 before 2023.8.4; 2025.3.0 — fixed in 2023.8.4
How to fix
Upgrade to a fixed version: Puppet Enterprise 2023.8.4. Check the vendor advisory for mitigations.
References
- https://portal.perforce.com/s/detail/a91PA000001SiDdYAK
- http://seclists.org/fulldisclosure/2026/Sep/9
Get alerted when CVE-2025-5459 or the next vulnerability affects your stack