What’s Vulnerable › Vulnerabilities
CVE-2025-54597
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-27 · updated 2026-06-17
- Weakness: CWE-79
Description
LinuxServer.io Heimdall before 2.7.3 allows XSS via the q parameter.
Affected products
- linuxserver Heimdall: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: linuxserver Heimdall 2.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/linuxserver/Heimdall/commit/d1a96dd752ba30dc56380400dd2587d8abb8e9d1
- https://github.com/linuxserver/Heimdall/compare/v2.7.2...v2.7.3
Get alerted when CVE-2025-54597 or the next vulnerability affects your stack