What’s Vulnerable › Vulnerabilities
CVE-2025-54604
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Bitcoin Core through 29.0 allows Uncontrolled Resource Consumption (issue 1 of 2).
Affected products
- Bitcoin Core: before 30.0 — fixed in 30.0
How to fix
Upgrade to a fixed version: Bitcoin Core 30.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2025/10/24/disclose-cve-2025-54604/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://github.com/bitcoin/bitcoin/releases
Get alerted when CVE-2025-54604 or the next vulnerability affects your stack