What’s Vulnerable › Vulnerabilities
CVE-2025-5472: Denial of Service via Uncontrolled Recursive JSON Parsing in JSONReader in run-llama/llama_index
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-07 · updated 2026-06-17
- Weakness: CWE-674
Description
The JSONReader in run-llama/llama_index versions 0.12.28 is vulnerable to a stack overflow due to uncontrolled recursive JSON parsing. This vulnerability allows attackers to trigger a Denial of Service (DoS) by submitting deeply nested JSON structures, leading to a RecursionError and crashing applications. The root cause is the unsafe recursive traversal design and lack of depth validation, which makes the JSONReader susceptible to stack overflow when processing deeply nested JSON. This impacts the availability of services, making them unreliable and disrupting workflows. The issue is resolved in version 0.12.38.
Affected products
- run-llama/llama_index: from 0.12.28 before 0.12.38 — fixed in 0.12.38
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.12.38. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/c032843a02ce38fd8f284b2aa5a37fd1c17ae635
- https://huntr.com/bounties/df187bda-7911-4823-a19a-e15b2c66b0d4
Get alerted when CVE-2025-5472 or the next vulnerability affects your stack