What’s Vulnerable › Vulnerabilities
CVE-2025-54780: glpi-screenshot-plugin exposes local files in /ajax/screenshot.php
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-05 · updated 2026-06-17
- Weakness: CWE-73
Description
The glpi-screenshot-plugin allows users to take screenshots or screens recording directly from GLPI. In versions below 2.0.2, authenticated user can use the /ajax/screenshot.php endpoint to leak files from the system or use PHP wrappers. This is fixed in version 2.0.2.
Affected products
- cconard96 glpi-screenshot-plugin: before 2.0.2
References
- https://github.com/cconard96/glpi-screenshot-plugin/commit/49215b53a05dc792719b69c098df80100208c2c8
- https://github.com/cconard96/glpi-screenshot-plugin/security/advisories/GHSA-x6mp-jhxw-9xrp
Get alerted when CVE-2025-54780 or the next vulnerability affects your stack