What’s Vulnerable › Vulnerabilities
CVE-2025-54782: @nestjs/devtools-integration's CSRF to Sandbox Escape Allows for RCE against JS Developers
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 53.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-02 · updated 2026-06-17
- Weakness: CWE-77
Description
Nest is a framework for building scalable Node.js server-side applications. In versions 0.2.0 and below, a critical Remote Code Execution (RCE) vulnerability was discovered in the @nestjs/devtools-integration package. When enabled, the package exposes a local development HTTP server with an API endpoint that uses an unsafe JavaScript sandbox (safe-eval-like implementation). Due to improper sandboxing and missing cross-origin protections, any malicious website visited by a developer can execute arbitrary code on their local machine. The package adds HTTP endpoints to a locally running NestJS development server. One of these endpoints, /inspector/graph/interact, accepts JSON input containing a code field and executes the provided code in a Node.js vm.runInNewContext sandbox. This is fixed in version 0.2.1.
Affected products
- nestjs Devtools-Integration: before 0.2.1 — fixed in 0.2.1
How to fix
Upgrade to a fixed version: nestjs Devtools-Integration 0.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/JLLeitschuh/nestjs-devtools-integration-rce-poc
- https://github.com/JLLeitschuh/nestjs-typescript-starter-w-devtools-integration
- https://github.com/nestjs/nest/security/advisories/GHSA-85cg-cmq5-qjm7
- https://nodejs.org/api/vm.html
- https://socket.dev/blog/nestjs-rce-vuln
- https://github.com/nestjs/nest/security/advisories/GHSA-85cg-cmq5-qjm7
Get alerted when CVE-2025-54782 or the next vulnerability affects your stack