What’s Vulnerable › Vulnerabilities

CVE-2025-54784: SuiteCRM is vulnerable to Cross Site Scripting (XSS) through its email viewer

Description

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. There is a Cross Site Scripting (XSS) vulnerability in the email viewer in versions 7.14.0 through 7.14.6. An external attacker could send a prepared message to the inbox of the SuiteCRM-instance. By simply viewing emails as the logged-in user, the payload can be triggered. With that, an attacker is able to run arbitrary actions as the logged-in user - like extracting data, or if it is an admin executing the payload, takeover the instance. This is fixed in versions 7.14.7.

Affected products

How to fix

Upgrade to a fixed version: salesagility SuiteCRM 7.14.7, 8.8.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-54784 or the next vulnerability affects your stack