What’s Vulnerable › Vulnerabilities
CVE-2025-54792: LocalSend is Vulnerable to Man-in-the-Middle Attacks, Leading to File Interception
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-01 · updated 2026-06-17
- Weakness: CWE-300
Description
LocalSend is an open-source app to securely share files and messages with nearby devices over local networks without needing an internet connection. In versions 1.16.1 and below, a critical Man-in-the-Middle (MitM) vulnerability in the software's discovery protocol allows an unauthenticated attacker on the same local network to impersonate legitimate devices, silently intercepting, reading, and modifying any file transfer. This can be used to steal sensitive data or inject malware, like ransomware, into files shared between trusted users. The attack is hardly detectable and easy to implement, posing a severe and immediate security risk. This issue was fixed in version 1.17.0.
Affected products
- localsend: before 1.17.0 — fixed in 1.17.0
How to fix
Upgrade to a fixed version: localsend 1.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/localsend/localsend/commit/e8635204ec782ded45bc7d698deb60f3c4105687
- https://github.com/localsend/localsend/releases/tag/v1.17.0
- https://github.com/localsend/localsend/security/advisories/GHSA-424h-5f6m-x63f
- https://github.com/localsend/localsend/security/advisories/GHSA-424h-5f6m-x63f
Get alerted when CVE-2025-54792 or the next vulnerability affects your stack