What’s Vulnerable › Vulnerabilities
CVE-2025-54799: Lego does not enforce HTTPS
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-07 · updated 2026-06-17
- Weakness: CWE-319
Description
Let's Encrypt client and ACME library written in Go (Lego). In versions 4.25.1 and below, the github.com/go-acme/lego/v4/acme/api package (thus the lego library and the lego cli as well) don't enforce HTTPS when talking to CAs as an ACME client. Unlike the http-01 challenge which solves an ACME challenge over unencrypted HTTP, the ACME protocol requires HTTPS when a client communicates with the CA to performs ACME functions. However, the library fails to enforce HTTPS both in the original discover URL (configured by the library user) and in the subsequent addresses returned by the CAs in the directory and order objects. If users input HTTP URLs or CAs misconfigure endpoints, protocol operations occur over HTTP instead of HTTPS. This compromises privacy by exposing request/response details like account and request identifiers to network attackers. This was fixed in version 4.25.2.
Affected products
- Go Github.Com/Go-Acme/Lego: through 4.25.1
- Go Github.Com/Go-Acme/Lego/V3: through 4.25.1
- Go Github.Com/Go-Acme/Lego/V4: before 4.25.2 — fixed in 4.25.2
- go-acme lego: before 4.25.2
How to fix
Upgrade to a fixed version: Go Github.Com/Go-Acme/Lego/V4 4.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/go-acme/lego/commit/238454b5f74f3cfcbb244ff0d0dc914a4ad44b96
- https://github.com/go-acme/lego/security/advisories/GHSA-q82r-2j7m-9rv4
Get alerted when CVE-2025-54799 or the next vulnerability affects your stack