What’s Vulnerable › Vulnerabilities
CVE-2025-54813: Apache Log4cxx: Improper escaping with JSONLayout
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-22 · updated 2026-06-17
- Weakness: CWE-117
Description
Improper Output Neutralization for Logs vulnerability in Apache Log4cxx. When using JSONLayout, not all payload bytes are properly escaped. If an attacker-supplied message contains certain non-printable characters, these will be passed along in the message and written out as part of the JSON message. This may prevent applications that consume these logs from correctly interpreting the information within them. This issue affects Apache Log4cxx: before 1.5.0. Users are recommended to upgrade to version 1.5.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Log4cxx: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Log4cxx 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/logging-log4cxx/pull/512
- https://logging.apache.org/security.html#CVE-2025-54813
- http://www.openwall.com/lists/oss-security/2025/08/22/3
- https://lists.debian.org/debian-lts-announce/2025/10/msg00002.html
Get alerted when CVE-2025-54813 or the next vulnerability affects your stack