What’s Vulnerable › Vulnerabilities
CVE-2025-54820
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A Stack-based Buffer Overflow vulnerability [CWE-121] vulnerability in Fortinet FortiManager 7.4.0 through 7.4.2, FortiManager 7.2.0 through 7.2.10, FortiManager 6.4 all versions may allow a remote unauthenticated attacker to execute unauthorized commands via crafted requests, if the service is enabled. The success of the attack depends on the ability to bypass the stack protection mechanisms.
Affected products
- Fortinet FortiManager: from 6.4.0 before 7.2.11; from 7.4.0 before 7.4.3 — fixed in 7.2.11, 7.4.3
How to fix
Upgrade to a fixed version: Fortinet FortiManager 7.2.11, 7.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54820 or the next vulnerability affects your stack