What’s Vulnerable › Vulnerabilities
CVE-2025-54854: BigIP APM Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-08
- Weakness: CWE-125
Description
When a BIG-IP APM OAuth access profile (Resource Server or Resource Client) is configured on a virtual server, undisclosed traffic can cause the apmd process to terminate. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 BIG-IP APM: from 15.1.0 before 15.1.10.8; from 16.1.0 before 16.1.6.1; from 17.1.0 before 17.1.3; from 17.5.0 through 17.5.1 — fixed in 15.1.10.8, 16.1.6.1, 17.1.3
How to fix
Upgrade to a fixed version: F5 BIG-IP APM 15.1.10.8, 16.1.6.1, 17.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-54854 or the next vulnerability affects your stack