What’s Vulnerable › Vulnerabilities
CVE-2025-54867: Youki Symlink Following Vulnerability
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-61
Description
Youki is a container runtime written in Rust. Prior to version 0.5.5, if /proc and /sys in the rootfs are symbolic links, they can potentially be exploited to gain access to the host root filesystem. This issue has been patched in version 0.5.5.
Affected products
- youki-dev youki: before 0.5.5 — fixed in 0.5.5
How to fix
Upgrade to a fixed version: youki-dev youki 0.5.5. Check the vendor advisory for mitigations.
References
- https://github.com/youki-dev/youki/commit/0d9b4f2aa5ceaf988f3eb568711d2acf0a4ace37
- https://github.com/youki-dev/youki/releases/tag/v0.5.5
- https://github.com/youki-dev/youki/security/advisories/GHSA-j26p-6wx7-f3pw
Get alerted when CVE-2025-54867 or the next vulnerability affects your stack