What’s Vulnerable › Vulnerabilities
CVE-2025-54869: FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-06 · updated 2026-06-17
- Weakness: CWE-770
Description
FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.
Affected products
- Setasign FPDI: before 2.6.3
References
- https://github.com/Setasign/FPDI/commit/ba671ba9221cffd32c2dda87316c19f522a1c5f0
- https://github.com/Setasign/FPDI/security/advisories/GHSA-jxhh-4648-vpp3
Get alerted when CVE-2025-54869 or the next vulnerability affects your stack