What’s Vulnerable › Vulnerabilities
CVE-2025-5488: WP Masonry & Infinite Scroll <= 2.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Masonry & Infinite Scroll plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wmis' shortcode in all versions up to, and including, 2.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- kaushik07 WP Masonry & Infinite Scroll: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: kaushik07 WP Masonry & Infinite Scroll 2.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-masonry-infinite-scroll/trunk/includes/functions.php#L227
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3314905%40wp-masonry-infinite-scroll&new=3314905%40wp-masonry-infinite-scroll&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/656c6236-55e6-4989-8f3d-2d2f81ab0093?source=cve
Get alerted when CVE-2025-5488 or the next vulnerability affects your stack